Partage

[Windows 7]Problème des jeux en plein écran

Des bandes noires apparaissent sur les côtés

Le 25 octobre 2009 à 13:40:44

Bonjour :) ,
J'ai reçu Windows 7 et j'ai fait la mise à jour a partir de Vista, donc la mise à niveau en concervant tous ses fichiers.
Cependant, j'ai un gros problème, pour certains jeux en plein écran, des bandes noires apparaissent sur le côte gauche et droit, donc il y a qu'une partie de l'écran qui est utilisé.
Y a t-il une solution à ce problème, sachant que sur Vista l'écran était utilisé entièrement?
Merci pour votre réponse :D !
Publicité
Le 25 octobre 2009 à 13:40:44
Le 25 octobre 2009 à 13:47:07

Utilise une résolution adaptée à ton écran.

Tu dois probablement avoir un écran large (16:10 ou 16:9), et tu dois utiliser une résolution 4:3.

Selon les drivers, DirectX,... l'image est soit adaptée pour prendre tout l'écran, mais en étant déformée, soit des bandes sont ajoutées pour garder une image normale (pas étirée).
Le 25 octobre 2009 à 14:10:22

Citation : Strimy

Utilise une résolution adaptée à ton écran.

Ma résolution est adaptée à mon écran, elle prend toute la place, lorsque je ne suis pas en plein écran.

Citation : Strimy

Tu dois probablement avoir un écran large (16:10 ou 16:9), et tu dois utiliser une résolution 4:3.

J'ai une résolution 4:3 large avec un écran 22 pouces, c'est un écran 16:9 ?

Sinon, sur Vista, avec la même configuration, le même écran, toute l'image était occupée pour les jeux en plein écran.
Le 25 octobre 2009 à 14:17:27

Citation

Ma résolution est adaptée à mon écran, elle prend toute la place, lorsque je ne suis pas en plein écran.


Mais tu ne dois pas être à la résolution native de l'écran, ni même sur une résolution qui correspond à la largeur de ton écran.
Certains jeux, selon le moteur (j'ai surtout remarqué avec Crysis en DirectX 10) conserve la bonne image plutôt que de l'étirer pour remplir l'écran.

Ton écran 22" (généralement 16:10) doit probablement avoir une résolution de 1680x1050, il faut donc que tu utilises cette résolution pour le bureau et les jeux.
Dans le cas où ta carte graphique est un peu faiblarde, tu peux tenter d'utiliser du 1440x900 ou du 1280x800 (ce qui peut avoir pour conséquence de rendre l'image légèrement floue, ca dépend de l'écran).
Le 25 octobre 2009 à 14:17:52

Tu as une nvidia je pense ?
Le 25 octobre 2009 à 15:00:16

Citation

Ton écran 22" (généralement 16:10) doit probablement avoir une résolution de 1680x1050, il faut donc que tu utilises cette résolution pour le bureau et les jeux.
Dans le cas où ta carte graphique est un peu faiblarde, tu peux tenter d'utiliser du 1440x900 ou du 1280x800 (ce qui peut avoir pour conséquence de rendre l'image légèrement floue, ca dépend de l'écran).


Ben j'ai essayé la résolution 1680x1050, mais c'est trop petit et ça me casse les yeux et ça ne change rien par raport à l'image qui n'occupe pas toute la place des jeux en plein écran.
Sur Vista, j'étais sur une résolution bien plus faible et tout marchait correctement.

Citation

Tu as une nvidia je pense ?


Oui, une NVIDIA GeForce 9500 GT :p .
Le 25 octobre 2009 à 15:49:35

1/ Driver à jour avec ta bonne version de Windows 7 ?( X64 ou X86(architecture de l'os))

2/ Sur le bureau > Clic droit > Panneau de configuration Nvidia
Ensuite dans ce panneau de configuration de ta carte Nvidia
Sélectionne dan le menu à gauche "Régler la taille et la position du bureau"
Et essaye les 4 options qui sont a ta disposition dans le menu qui apparait sur la droite.

-Utiliser la mise à l'échelle NVIDIA.
-Utiliser la mise à l'échelle NVIDIA avec un rapport largeur/hauteur fixe.
-Utiliser la mise à l'échelle intégré a l'ecran.
-Ne pas mettre a l'échelle.

Je te propose donc d'essayer chacune des 4 options pour le jeu avec lesquelles tu as un problème de bande noir.

Sinon je ne sais pas, bonnes chances ;)

P.S: Je parle en connaissance de cause, car j'avais exactement le même problème, j'espère, que pour toi ce sera résolu
Le 25 octobre 2009 à 17:25:55

J'arrive pas à ouvrir la panneau de configuration de la carte NVIDIA, quand je double-clique dessus, j'ai rien qui s'affiche :( .
Sinon, mon architecture est en x86 (32 bits).

Mais je ne pense pas que ce soit la carte graphique car sur le PC de ma mère sous 7 également, c'est pareil.
Le 25 octobre 2009 à 17:51:24

Bah... déjà ta un problème de driver...
normalement tu dois avoir accès au panel de gestion de ta carte graphique


Mise a jour OS > OS n'a jamais rien donné de bon... faut toujours partir sur des bases saines (en plus quand il s'agit de Windows...(vous savez bsod et tout ça ^^)
Le 25 octobre 2009 à 21:15:58

C'est bon, je peux accéder au panneau de configuration de ma carte, j'ai mis les drivers à jour.

Voici juste un exemple de mon problème:
Image utilisateur
Il y a des rectangles noirs sur les côtés :(
Le 25 octobre 2009 à 21:36:31

Citation

Ben j'ai essayé la résolution 1680x1050, mais c'est trop petit et ça me casse les yeux et ça ne change rien par raport à l'image qui n'occupe pas toute la place des jeux en plein écran.


Trop petit sur un 22"? T'a pas des problèmes de vues par hasard ? (je dis ca parce que j'ai cette résolution sur un 15,4")
En tout cas, tu peux toujours augmenter la taille de l'affichage si ca te dérange (clic droit sur le bureau -> Résolution de l'écran -> Make text and other items larger or smaller (en francais, ca doit être "Rendre le texte et les autres éléements plus gros ou plus petit"). Et là, tu passe à 125% ou 150.
Il serait intéressant de connaitre le modèle de ton écran. C'est pas normal que tu ais des bandes noires en utilisant la résolution native de l'écran dans le jeu. Donc il faudrait connaitre la résolution native de ton écran, et la résolution que tu utilises dans tes jeux.
Le 25 octobre 2009 à 22:40:36

Même problème avec moi, j'ai une NVIDIA GeForce 9300 GE, j'ai fait les mise à jours de tous les pilote via Windows Update puis j'ai vérifier manuellement tout est a jour, je c'est pas comment faire :S

PS : J'ai le NVIDIA Control Panel (en anglais).
Le 26 octobre 2009 à 14:31:34

Citation

Trop petit sur un 22"? T'a pas des problèmes de vues par hasard ?


Si, je suis myope mais bon j'aime bien quand c'est grand et pas petit (j'arrive à voir sur la résolution 1680x1050 mais j'aime pas, je mettais toujours en 1280 x 768 :p ).

Citation

Il serait intéressant de connaitre le modèle de ton écran. C'est pas normal que tu ais des bandes noires en utilisant la résolution native de l'écran dans le jeu. Donc il faudrait connaitre la résolution native de ton écran, et la résolution que tu utilises dans tes jeux.


Mon écran c'est un LG 22", la résolution native c'est normalement 1680x1050, et la résolution dans les jeux c'est 1280 x 1024 normalement.
A noter que j'ai essayé avec un autre écran (un Acer 22") et ça ne change rien :( .
Le 26 octobre 2009 à 14:38:22

Pour le bureau, tu peux mettre en 1680x1050, et augmenter les DPI pour avoir une taille qui te convienne (comme j'ai expliqué).

Si dans tes jeux tu utilises du 1280x1024, je te recommande de changer pour une résolution qui soit du même ratio que ton écran, comme déjà dit: tu peux tenter d'utiliser du 1440x900 ou du 1280x800.
Je suis persuadé que ton problème vient bien d'une résolution inadaptée. Les solutions proposées par neo-cortex auront pour effet d'étirer l'image. Ainsi, un cercle apparaitrai ovale, et un carré sera un rectangle, ce qui est loin d'être l'idéal.
Le 26 octobre 2009 à 15:01:54

Bah en fait, dans les jeux, je ne pas changer la résolution (y a juste marqué Fullscreen).
Et puis je préfère que mes jeux utilisent toute la place en plein écran, tant pis pour la qualité.
Le 26 octobre 2009 à 15:28:27

Pour Peggle je pense que c'est normal étant donné que les options d'affichage sont très restreintes... Si les seuls résolutions proposées sont au format 4:3, tu auras forcément des bandes noires sur les côtés, pour éviter que l'image soit déformée.
Le 31 octobre 2009 à 21:26:00

J'ai exactement le même problème, à savoir que sous Vista, mes jeux pas à la résolution maximale étaient étiré, et la sous 7, ils prennent la résolution des options et mettent du noir autour.

Je viens d'essayer avec Star wars : Kotor, qui tourne en 1024x768 maxi, et le jeu est entouré d'un carré noir, alors que sous Vista il était étiré...

J'ai une Nvidia aussi, et une réso native de 1440*900.

Edit : La mise à l'échelle est réglée sur Utiliser la mise à l'échelle intégré, et quand je la change et que j'applique, ça reviens sur intégré... Comment forcer cela?
Le 31 octobre 2009 à 22:14:35

Je pense plutot que c'est du à Windows 7 alors.
Le 31 octobre 2009 à 22:43:40

Ou alors au pilote de Nvidia qui fait mal sont boulot avec seven, puisque apparement ça marche correctement sur les ATI
Le 31 octobre 2009 à 23:51:19

Pour KOTOR, il y a une modification pour utiliser une résolution large.

Mais ce n'est un problème de driver qui fait mal son boulot, juste un choix d'afficher une image normale.
Le 1 novembre 2009 à 1:36:20

Je pense qu'il fait mal son boulot malgré tout car il ne veux pas switcher de mode.


Edit : L'installation des nouveau pilotes Beta pour ma carte graphique de portable (8600mGT) à réglé le problème, c'était bien une histoire de pilotes.
Le 2 novembre 2009 à 21:59:12

Bon mon problème apparaît aussi quand je regarde des vidéos Youtube en plein écran:
Image utilisateur
Vous voyez bien les bandes noires sur les côtés?
Le 2 novembre 2009 à 22:03:38

T'a le don d'inventer des problèmes ?
C'est juste la vidéo qui a une largeur inférieure au player...
Le 3 novembre 2009 à 0:11:14

Oui, ça par contre c'est normal.
Le 2 décembre 2009 à 19:10:13

Bonsoir tout le monde, j'ai installé windows 7 hier soir et je me retrouve qu'avec des problèmes.. Tout d'abord un probléme de son que je pense avoir résolu mais l autre probléme est que je n'arrive pas a mettre counter strike condition zero ni trackmania en pleine ecran et sa me rend fou ^^
J'ai un pc portable Asus avec une carte ATI radeon hd 4570 graphics 512
Je joue a counter en 640x480
Si quelqu'un à la solution a ce problème qu'il/elle me tienne au courant s'il vous plait.
Merci d'avance.
Le 3 décembre 2009 à 19:00:40

Citation : neo-cortex

1/ Driver à jour avec ta bonne version de Windows 7 ?( X64 ou X86(architecture de l'os))

2/ Sur le bureau > Clic droit > Panneau de configuration Nvidia
Ensuite dans ce panneau de configuration de ta carte Nvidia
Sélectionne dan le menu à gauche "Régler la taille et la position du bureau"
Et essaye les 4 options qui sont a ta disposition dans le menu qui apparait sur la droite.

-Utiliser la mise à l'échelle NVIDIA.
-Utiliser la mise à l'échelle NVIDIA avec un rapport largeur/hauteur fixe.
-Utiliser la mise à l'échelle intégré a l'ecran.
-Ne pas mettre a l'échelle.

Je te propose donc d'essayer chacune des 4 options pour le jeu avec lesquelles tu as un problème de bande noir.

Sinon je ne sais pas, bonnes chances ;)

P.S: Je parle en connaissance de cause, car j'avais exactement le même problème, j'espère, que pour toi ce sera résolu


As-tu essayer cette solution dans le panneau de configuration nVidia?
Car le problème vient majoritairement de là.
Le 6 février 2010 à 14:05:52

Bonjour, désolé de re-upper le sujet, mais en fait j'ai le même problème de bandes noires avec ATI.
Je suis sous Windows 7 32 bits, avec un ordinateur portable écran 1440x900.
Or, des jeux comme Bataille Pour La Terre Du Milieu 2 par exemple ont des bandes noires.
J'ai reformaté, avant j'étais aussi en Windows 7, c'était juste histoire de gagner un peu en rapidité vu que je reformate assez souvent ^^
Bref, j'ai mes drivers à jour via le site d'ATI, je posséde une ATI Mobility Radeon HD 4650. J'ai recherché dans le cataclyst s'il y avait une histoire de mise à l'échelle comme dans celui de Nvidia, sans succès.
Je vous remercie d'avance pour vos réponses,
Cordialement,
rrSP.
Le 6 février 2010 à 14:13:08

T'a bien réglé la résolution dans ton jeu ?
Le 7 février 2010 à 14:56:33

@Dthibault : +1 :) !

@rrSP : Voici la démarche à adopter, si tu as une carte graphique ATI :) ! => http://tiny.cc/atiscale

J'ai moi aussi connu ce problème...
Le 21 février 2011 à 19:05:48

Salut, j'ai le même problème, j'ai mit a jour mes drivers Nvidia de la version 258 à la version 266 (la dernière en date), et mes jeux sont passés du 16:9 au 4:3. A mon avis, c'est les nouveaux drivers qui ne prennent plus en charge les anciens jeux DX9 maxi en résolution optimale, car dés que je repasse à l'ancienne version, hop ça redevient plein écran sans bande noire sur les cotés.. et ça me fait cela également sur mon portable qui a une ATI HD5470, et mon pc a une GeForce GTX260..

OS: Windows 7 64 bits

[Windows 7]Problème des jeux en plein écran

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown