Partage

Mes smileys sont moches ^^

Ils ne s'affichent pas correctement ...

Le 4 août 2009 à 17:23:10

Bonjour,

J'ai commencé à dévelloper mon site voilà quelques temps, et, même si ce problème n'est pas très important, j'aimerais le règler. Quand j'affiche un smiley sur le site, il ne s'affiche pas correctement. j'utilise les smileys du SdZ, et il me rend ceci pour le clin d'oeil :

Image utilisateur au lieu de ;) .

Pas très esthétique tout ca :p .

Donc je ne comprend pas du tout le problème, de plus quand je l'affiche seul dans le navigateur (sans la page autour), il est affiché correctement !

Voilà, merci d'avance de l'aide que vous m'apporterez :)
Publicité
Le 4 août 2009 à 17:23:10
Le 4 août 2009 à 17:27:59

J'aurais bien du que c'était du à un problème de détourage, problème récurrent lorsqu'on a des formes arrondies sur un gif, mais là, c'est un png, je ne sais pas si ça entre en compte aussi :s
Le 5 août 2009 à 1:27:45

essaye d'enregistrer ton smileys sur ton ordinateur ouvre le avec photo filtre ou autre et change le de format et après envoi le sur ton site et si le problème persiste essaye de trouve d'autre smileys comme ceux de msn par exemple ;)
Le 5 août 2009 à 8:47:49

Mon smileys est sur mon PC !! Je le regarde en localhost ! J'essaie ce soir, maintenant je ne peux pas ;) .
Le 5 août 2009 à 21:29:44

Salut
Je viens d'enregistrer les deux smiley sur mon pc et en fait ton problème vient du fait que le smiley original du sdz est un fait sur un carré de 19 pixels de coté ton smiley à une hauteur de 20 pixels pour 19 pixels de largeur.
Le 5 août 2009 à 23:19:34

Pendant un moment j'ai cru que tu parlais du fond blanc, mais jpense que tu parles en fait tu trait noir en bas ? et du flou qu'il y a.

Si oui, en effet réduit ton image de 1px de moins, tu enlèves le 1ox de trop en bas. Et tout ira bien ^^
Le 6 août 2009 à 2:32:48

Le problème n'est pas là :) . Quand j'affiche le fichier image dans le navigateur, tout va bien. Ce qui pose problème, ce n'est pas l'image en elle-même.

A+ et merci de ton aide ;)
Le 6 août 2009 à 2:54:08

Exact... relis bien la réponse de kenny61.
Le 6 août 2009 à 13:46:11

Désolé, j'avais zappé la réponse de 3kn0x :p . Ok, je regarde :) .

Dans les propriétés de mon smileys, il est 19*19. J'essaie de re télécharger les smileys :) .

Toujours pareil. Ils sont bien en 19*19 et ils me les affichent mal
Le 6 août 2009 à 14:23:03

Enregistre le smiley depuis ton navigateur sur ton bureu par exemple puis regarde les propriétés, car chez moi ton smiley fait 20*19px.

A gauche le smiley original et a droite le tiens, grossis 8x avec paint
Image utilisateur

Donc tu nous dit que ce n'est pas le fichier d'origine qui est le problème donc regarde ton code source et essaye de mettre
class="smiley19"

dans la balise "img" aux smileys de 19px de haut (certains font plus) et rajoute le code css :
.smiley
{
height: 19px;
}
Le 6 août 2009 à 14:26:56

J'ai fait ceci, mais rien ne change : le smiley fait 19 px. J'ai essayé de mettre 18*18, mais il me le rapetisse et ne change rien ...

Je vais essayé de les modifier pour voir ...
Le 6 août 2009 à 14:36:11

Au passage, as tu eu l'autorisation d'utiliser les smileys du Site du Zéro ?
Tout contenu présent sur un site est protégé. Sans autorisation tu n'as donc pas le droit de les utiliser.
Le 6 août 2009 à 14:44:07

@ Bob-le-zéro : http://www.siteduzero.com/news-62-541- [...] ys-sdzv3.html tu auras la reponse pour les smileys

Sinon pour l'histoire des smileys qui sont trop haut la je ne sais plus quoi dire :'(
Le 6 août 2009 à 16:46:28

J'ai vérifié Bob-le-zéro : lis la news au dessus ;) . Ce sont les meilleurs smileys que je connaisse, en plus libre, donc je les utilisent :) .

Je vais poser la question à quelqu'un que je connais, j'aurais peut-être la réponse :) . Si je l'ai, je vous la dirai :)
Le 6 août 2009 à 19:04:23

Ah je savais pas, ça va bien me servir ;) .
Merci
Le 17 octobre 2009 à 22:46:13

Je relance le sujet, car je n'ai toujours pas la réponse ...

Merci d'avance de votre aide
Le 18 octobre 2009 à 17:54:47

Réponse peut-être un peu ... mais vu que tu as utilisé Paint et que tu as vu où se situe la différence entre les pixels de l'original et de la copie, pourquoi ne pas modifier ces fameux pixels ?
Le 18 octobre 2009 à 18:06:54

Après quelques tests, sous FF, les smileys ne s'affichent pas correctement, mais sous IE, ils sont normaux !! Je ne comprend vraiment pas ...

Citation : Cindynus

Réponse peut-être un peu ... mais vu que tu as utilisé Paint et que tu as vu où se situe la différence entre les pixels de l'original et de la copie, pourquoi ne pas modifier ces fameux pixels ?



Le problème n'est pas là : ce doit être l'encodage qui pose problème, mais dans ce cas, je ne sais pas comment faire ...
Le 18 octobre 2009 à 19:05:17

Moi je pensse sérieusement que c'est ton fond, ou en tout cas il y a un rapport
Le 18 octobre 2009 à 19:08:06

Comment ca ? Quel fond ?
Le 19 octobre 2009 à 13:36:43

Il faut que tu passes le smiley en mode "couleurs indexées". Photoshop réalise très bien cette option. Sinon, quand tu enregistre l'émoticône, tu devrais obtenir la même... Bizarre. "Clic droit > Enregistrer sous" est différent que "je coulisse sur le bureau".

Une fois que tu as obtenu le smiley, évite aussi de l'éditer.


Cordialement.
Le 29 octobre 2009 à 0:16:37

Je relance le sujet, par manque de solution. Le fait d'utiliser les couleurs indexées ne change pas mon problème : le mode est déjà en "Couleurs indexées" ...

Merci quand même de ta réponse
Le 29 octobre 2009 à 9:47:49

Au fait j'aimerais juste savoir :
on a le droit d'utiliser les smiley du site du zéro?
C'est autorisé?
Le 29 octobre 2009 à 11:20:31

Citation : xababafr

Au fait j'aimerais juste savoir :
on a le droit d'utiliser les smiley du site du zéro?
C'est autorisé?


Tu as lu le topic ? ...


Le trait noir en bas est peut être le haut du smiley qui essaye de se répéter, je ne sais pas si tu vois ce que je veux dire...
Petit dessin : Image utilisateur <=> Image utilisateur
La partie plus claire est la partie du smiley qui se répète mais qui ne se voit pas. Par contre on voit bien que le trait noir est là, et que c'est bien le sommet du crane.

Je n'ai pas ton code, je ne peux donc pas te donner de solution mais l'idée est d'interdire à l'image de se répéter.

Bonne journée
Le 29 octobre 2009 à 12:12:08

Non, ce n'est pas ça car quand tu regarde le zoom dans ton cas les deux dernierères lignes devraient être noires alors que ce n'est que la dernière qui l'est!
je ne sais pas si je suis clair... :-°
Le 29 octobre 2009 à 12:18:14

Oui, mais c'est parce que le smiley qu'il nous a donné : Image utilisateur c'est un screenshot depuis son site web, et tu peux d'ailleurs remarquer que la qualité n'est pas la même (à cause du logiciel qu'il a utilisé pour sauvegarder l'image)...d'ailleurs il a précisé que le problème ne venait pas du smiley en lui même...
Si tu avais lu le topic :D

Mes smileys sont moches ^^

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown