Partage

Integration EWZRecaptchaBundle(symphony2)

Le 22 septembre 2012 à 19:51:56

Bonsoir,
J'essaye d'intégrer le bundle EWZRecaptchaBundle dans le framework symphony2 mais malheureusement ça marche pas j’obtiens toujours le message suivant.Est ce que quelqu'un peut m'aider pour savoir la source de l'erreur.
merci d'avance

message d'erreur:
Fatal error: Declaration of EWZ\Bundle\RecaptchaBundle\Form\Type\RecaptchaType::buildView() must be compatible with that of Symfony\Component\Form\FormTypeInterface::buildView() in /opt/lampp/htdocs/AgencePublicite/vendor/excelwebzone/recaptcha-bundle/EWZ/Bundle/RecaptchaBundle/Form/Type/RecaptchaType.php on line 147
Publicité
Le 22 septembre 2012 à 19:51:56
Le 22 septembre 2012 à 19:54:08

Utilises-tu des versions compatibles de ton bundle et de symfony (ça s'écrit avec un "f", symphony est un CMS qui n'a rien à voir, je crois)?
Vous utilisez git et (Composer, Sismo, Symfony ou ctags)? Simplifiez vous la vie avec des hooks!
Le 22 septembre 2012 à 20:07:49

j'utilise le framwork symfony 2 la version 2.0.15.Pour le bundle EWZRecaptchaBundle j'utilise une version que j'ai récupéré ici avec l'utile composer https://github.com/excelwebzone/EWZRecaptchaBundle.
merci d'avance
Le 22 septembre 2012 à 20:09:57

Cette version est-elle compatible avec la version du bundle que tu as choisie?
Vous utilisez git et (Composer, Sismo, Symfony ou ctags)? Simplifiez vous la vie avec des hooks!
Le 22 septembre 2012 à 20:15:29

Du fait que je suis Débutant dans le framework symfony je ne peux pas juger s'il sont compatibles ou non.
Le 22 septembre 2012 à 20:26:22

En général, c'est noté dans la doc du bundle.
Vous utilisez git et (Composer, Sismo, Symfony ou ctags)? Simplifiez vous la vie avec des hooks!
Le 22 septembre 2012 à 20:37:07

Oui les deux versions sont compatibles.j'ai fait beaucoup de recherche sur le net mais j'ai pas trouve aucune solution pour ce problème.
Le 22 septembre 2012 à 20:54:52

Ah bon, eh bien si les deux versions sont compatibles, je ne vois pas ce que ça peut être. D'expérience, c'est typiquement le message qu'on a quand on se plante de version, mais puisque tu es sûr...
Vous utilisez git et (Composer, Sismo, Symfony ou ctags)? Simplifiez vous la vie avec des hooks!

Integration EWZRecaptchaBundle(symphony2)

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown