Partage

Ftp en Ms-dos ...

Et script automatisé

Le 14 octobre 2008 à 10:09:25

Bonjour à tous !!!

Je cherche a faire un script automatisé MS-dos : quand je le lancerai, il remplacerai un répertoire distant par un repertoire local ...

En gros, il remplacerait la version de mon site qui est déjà sur le serveur par la dernière que j'ai créé.

Je n'ai pas commencé le script, mais ai juste fait quelques essais en ms-dos (je suis sous xp).

Mais j'ai des trucs bizarres :


Connecté à 192.168.0.21.
220 Bienvenue sur mon serveur FTP !
Utilisateur (192.168.0.21:(none)) : ****
331 Please specify the password.
Mot de passe :
230 Login successful.
ftp> lcd C:\Documents and Settings\G******\Mes documents\Mes sites web\B***
lcd dossier local.
ftp> !dir
 Le volume dans le lecteur C n'a pas de nom.
 Le numéro de série du volume est 788D-93F4

 Répertoire de C:\Documents and Settings\G****

14/10/2008  09:58    <REP>          .
14/10/2008  09:58    <REP>          ..
07/10/2008  19:02    <REP>          Bureau
05/10/2008  14:59    <REP>          Contacts
04/10/2008  15:54    <REP>          Favoris
11/10/2008  14:13             1 277 intlname.ols
12/10/2008  14:56    <REP>          Logs
17/09/2008  22:58    <REP>          Menu Démarrer
10/10/2008  22:21    <REP>          Mes documents
               1 fichier(s)            1 277 octets
               9 Rép(s)  167 886 819 328 octets libres
ftp> lcd C:\Documents and Settings\G******\Mes documents\Mes sites web\B****
lcd dossier local.
ftp> lcd
Dossier local maintenant C:\Documents and Settings\******.
ftp>


Comme vous le voyez surement, je ne peux pas définir un dossier dans "mes documents" comme répertoire courant en local ...

Il reste bloqué dans mon fichier personnel ...

Étrange, non ?
Publicité
Le 14 octobre 2008 à 10:09:25
Le 14 octobre 2008 à 10:18:23

Le problème de situe probablement au niveau des noms de dossier contenant des espaces...
Le client FTP du DOS est peut-être un peu vieillot et ne gère pas correctement les noms contenant des espaces.
Si y'a pas d'accents dans mes messages c'est parce que je suis sur un clavier norvegien :)
Le 14 octobre 2008 à 14:33:10

si tu as des noms de dossier avec des espaces, il faut mettre des guillemets autour
donc:
lcd "C:\Documents and Settings\utilisateur\Mes Documents"
Le 14 octobre 2008 à 19:46:57

Merci ! Mais ...

Voilà mon script :

ftp ************
user bruno ***************
cd /public_html
lcd "C:\Documents and Settings\************\Mes documents\Mes sites web\Bruno\Synchro -- final"
mput *.*
close
quit
pause


Et j'ai tout ceci :

Image utilisateur
QUi se répète en continu ...

Qu'ai je mal fait ???

Merci !
Le 14 octobre 2008 à 19:55:59

Juste une précision :
Flouter le nom d'utilisateur ne sert à rien.
De plus, on peut presque lire "guillaume", si c'est pas ça bah ça change rien, et si c'est ça, bah ça change rien non plus

Flouter ton adresse IP locale ne sert à rien.
On peut très bien avoir tous la même....
Si y'a pas d'accents dans mes messages c'est parce que je suis sur un clavier norvegien :)
Le 14 octobre 2008 à 20:06:34

je sais, mais, en général, sur internet, lorsqu'on choisit un pseudo, c'est pour ne pas donner son nom ...

Par contre, pour l'ip locale, je suis d'accord, ca ne sert à rien, mais c'est plus par reflexe qu'autre choses (j'utilise souvent mon ip fixe en ftp) ...
Le 14 octobre 2008 à 21:18:43

Tu protèges ton prénom, et tu laisses ton nom dans ton adresse mail de ton profil ?
Du coup, maintenant j'ai ton nom et ton prénom, je vais...je vais hacker ton vélo! et la porte de ton garage et aussi ta boite aux lettres, et je finirais par frotter avec une éponge grattante toutes tes poêles tefal.
Si y'a pas d'accents dans mes messages c'est parce que je suis sur un clavier norvegien :)
Le 14 octobre 2008 à 22:26:29

Lol !!!

Je ne savais pas que l'adresse mail était visible ... Merci de le signaler ! Et qui te dis que c'est mon nom ^^ ? Pitié, prends la Télé, mais ne touches pas à mes poêles !!!

Bon ... Et mon MS-Dos ???
Le 15 octobre 2008 à 0:52:16

Ton script n'aurais pas comme nom "ftp.bat" ?
Si c'est le cas mets un autre nom et testes
Le 15 octobre 2008 à 19:13:40

Me revoilà !!

J'ai finalement créé deux fichiers :


ftp -s:transfert.txt
pause


et transfert.txt
open 192.168.0.21 user ****** *******************
cd /public_html
lcd "C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno\Synchro -- final"
mput *.*
close
quit
pause


Voilà le résultat :

C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno>ftp -s:tra
nsfert.txt
ftp> open 192.168.0.21 user bruno ****************
Utilisation : open Nom hôte [port]
ftp> cd /public_html
Non connecté.
ftp> lcd "C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno\
Synchro -- final"
Dossier local maintenant C:\Documents and Settings\Guillaume\Mes documents\Mes s
ites web\Bruno\Synchro -- final.
ftp> mput *.*
Non connecté.
ftp> close
Non connecté.
ftp> quit

C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno>pause
Appuyez sur une touche pour continuer...


Que puis je faire ??? Je ne comprend pas vraiment ce qui ne va pas ... Je précise, bien sur, que j'arrive à me connecter avec Filezilla ...
Le 17 octobre 2008 à 23:03:25

ton script est correct.
Quand tu lances connexion.bat qu'est ce que cela te donne comme message d'erreur?
Le 18 octobre 2008 à 13:42:55

Oups, dls, je n'avais pas vu, mais j'ai fait une erreur de copier/coller ...

J'ai changé le "voici le résultat" ...
Le 18 octobre 2008 à 14:01:01

ah ok, je vois l'erreur:
la commande open ne nécessite que le nom du serveur en argument donc:
transfert.txt
open 192.168.0.21 
bruno
**********
cd /public_html
lcd "C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno\Synchro -- final"
mput *.*
close
quit
pause
Le 18 octobre 2008 à 22:18:03

Merci, je testerai ça demain !!!
Le 23 octobre 2008 à 9:27:12

Ca fonctionne !!!

Le seul problème est qu'il n'y arrive pas avec des dossiers :

C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno>ftp -s:tra
nsfert.txt
ftp> open 192.168.0.21
Connecté à 192.168.0.21.
220 Bienvenue sur mon serveur FTP !
Utilisateur (192.168.0.21:(none)) :
331 Please specify the password.

230 Login successful.
ftp> cd /public_html
250 Directory successfully changed.
ftp> lcd "C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno\
Synchro -- final"
Dossier local maintenant C:\Documents and Settings\Guillaume\Mes documents\Mes s
ites web\Bruno\Synchro -- final.
ftp> mput *.*
mput index.php?
200 PORT command successful. Consider using PASV.
150 Ok to send data.
226 File receive OK.
ftp : 1026 octets envoyés en 0,00 secondes à 1026000,00 Ko/sec.
mput style.css?
200 PORT command successful. Consider using PASV.
150 Ok to send data.
226 File receive OK.
ftp : 488 octets envoyés en 0,00 secondes à 488000,00 Ko/sec.
mput test?
Erreur lors de l'ouverture du fichier local test.
ftp> close
221 Goodbye.
ftp> quit

C:\Documents and Settings\Guillaume\Mes documents\Mes sites web\Bruno>pause
Appuyez sur une touche pour continuer...


Savez vous comment faire ?

Ftp en Ms-dos ...

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown